Not logged inOcean Color Forum

The forum is locked.

The Ocean Color Forum has transitioned over to the Earthdata Forum (https://forum.earthdata.nasa.gov/). The information existing below will be retained for historical reference. Please sign into the Earthdata Forum for active user support.

Up Topic SeaDAS / SeaDAS - General Questions / [Errno 101] Network is unreachable
- By kimlotte Date 2018-04-19 13:02
Hello.

I am running this statement
modis_GEO.py A2018108105738.L1A_LAC

and I get this error:

Exception: [Errno 101] Network is unreachable
Exception: 'NoneType' object has no attribute 'status'
Traceback (most recent call last):
  File "/home/rcmrd/seadas-7.4/ocssw/scripts/modis_GEO.py", line 187, in <module>
    sys.exit(main())
  File "/home/rcmrd/seadas-7.4/ocssw/scripts/modis_GEO.py", line 175, in main
    m.utcleap()
  File "/home/rcmrd/seadas-7.4/ocssw/scripts/modules/modis_GEO_utils.py", line 140, in utcleap
    lut.get_luts()
  File "/home/rcmrd/seadas-7.4/ocssw/scripts/modules/LutUtils.py", line 127, in get_luts
    regex='^((?!\d+).)*' + suffix, check_times=True)
  File "/home/rcmrd/seadas-7.4/ocssw/scripts/modules/JsonUtils.py", line 269, in download_allfiles
    all_links = self.get_links(url, regex=regex)
  File "/home/rcmrd/seadas-7.4/ocssw/scripts/modules/JsonUtils.py", line 235, in get_links
    content = response.read()
AttributeError: 'NoneType' object has no attribute 'read'

I ran this statement to

python simple_python_connection_test.py

and I got this output:

read https://oceancolor.gsfc.nasa.gov/ successfully

Funny enough, it was working yesterday in the same computer but for some reason, it completely stopped working and hasn't worked ever since. I even shifted processing to another computer and I got this error.

Cannot create geolocation from A2018108105738.L1A_LAC; exiting.
Error! could not establish a network connection. Check your network connection.
If you do not find a problem, please try again later.

Would you help me narrow what the problem might be?

Regards,
James
- By seanbailey Date 2018-04-21 02:04
James,

How did you install the OCSSW package?
While the path suggests you have v7.4, the error belies this.  You have v7.5 of the OCSSW code installed.  We've been putting that out for while entirely unsupported as it's so we can test it before releasing.  Did you intend to install v7.5?

Sean
- By kimlotte Date 2018-04-23 06:14
Hello Sean.

I installed it as

./install_ocssw.py --install-dir=$HOME/ocssw --direct-broadcast --aqua --terra --npp

I followed the instructions from here  https://seadas.gsfc.nasa.gov/downloads/ 

Well, I intended to install the most up to date and stable SeaDAS.

Kind regards,
James
- By seanbailey Date 2018-04-23 13:13
Ah, I see.  We left off the --git-branch=<version> bit for the --direct-broadcast example...
Without it you get the most recent version, but since we're close to releasing the NEXT version, you got that one...which apparently wasn't yet stable :eek:

On Friday, some updates to v7.5 went in, so you probably can keep it - just rerun the command to get the updates:
./install_ocssw.py --install-dir=$HOME/ocssw --direct-broadcast --aqua --terra --npp --git-branch=v7.5

The problem you had should be resolved if you do so.  If it persists, well you can reinstall with v7.4, but you'll want to include --clean.
...and let us know.  I was hoping the updates made on Friday would be the releasable version.

Sean
Up Topic SeaDAS / SeaDAS - General Questions / [Errno 101] Network is unreachable

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill