Not logged inOcean Color Forum
Up Topic Products and Algorithms / Satellite Data Access / L1/L2 Browser error for large searches
- By b.detracey Date 2018-02-15 07:45
Hi,
The L1/L2 Browser keeps redirecting me to the .:. ERROR .:. page when I "Find Swaths" with a large search e.g. MODIS, CHL, N:82 S:39 W:-95 E:-42, 2004.  Is the search timing out?
- By norman Date 2018-02-15 09:21
Hi,

Yes, your search is probably timing out.  I get the same result.  I kept halving the
search time period until I got one which works (1 Jan - 15 Feb 2004).  That search
returned 572 scenes.
https://oceancolor.gsfc.nasa.gov/cgi/browse.pl?sub=level1or2list&per=CSTM&day=12418+46&sen=am&n=82&s=39&w=-95&e=-42&dnm=D

It does seem like we should be able to return a larger list than that (I'll run it by
our database experts), but there will still be limits to what we can support.  One
option is for you to do your searches piecemeal as in the example above.  Another
possibility would be to start with level-3 data.

Regards,
Norman
- By b.detracey Date 2018-02-15 13:21 Edited 2018-02-15 14:24
It never used to time out.:cry: This is a recent development. I have been using this method for a couple years to generate lists of files covering an area of interest.

EDIT: Similar searches for 2017, 2016, 2015, 2014, 2013, 2006 and 2005 do not fail. 2004 is special.
- By SeanBailey Date 2018-02-15 19:07
...we either need less smoke or more mirrors...or less mirrors and more smoke...
2004 is special because it seems to take a few seconds longer for the query to run than other years...not sure why that would be (perhaps a function of how/when the data were stored in the D, but since it does it is tripping over a server time0ut configuration - one that may have crept in during one of a number of extra  Spec... (uh...) special updates.  Once the a revised setting has been tested we'll implement it (or perhaps it's re-implement it) on the external servers and your queries will no longer get the dreaded triple dot page.  That'll probably be next week as tomorrow is Friday before a long weekend, and well, not a good idea to change the servers on such days :grin:

Sean
- By amsayer Date 2018-03-01 09:55
FYI I came online to post about a similar timeout error I am having today from the L1/L2 browser (https://oceancolor.gsfc.nasa.gov/cgi/browse.pl). In my case I am after SeaWiFS GAC level 1 data, whole mission, 20W-20E and 30S-10N. I haven't done this type of search in a few years but it used to work then with similar size regions.

If I restrict the search to a single year, I get the same timeout. (Except for 1997 but that was a partial year which explains it.)
- By SeanBailey Date 2018-03-01 10:29
Try again.  I just tried that query and it took 15 seconds for the entire mission.  Perhaps you hit the database during a cranky pre-coffee morning :wink:

Sean
- By amsayer Date 2018-03-01 11:30
Thanks! So, an update:
- On Google Chrome I still get the timeout.
- On Firefox I don't get the timeout there. But on the next order screen (where I select that I want extracts and the L1 data only), I get the same error message after pressing 'review order'. After a few times trying, it eventually went through to the next stage (where it lists the files, ~11k total in this case). On clicking 'submit your order' it then went to the same error page, but I got an order confirmation email (30a09020829cad54), so I am guessing it went through.

I am not sure why it times out some times but not others, or why there was the apparent browser dependence. So maybe some parts of the database (or my computer) still need some coffee. ;) Since the order went through it's ok but I thought I'd provide the info in case it is useful on your end.

This is from within the GSFC network, Windows 7, latest Chrome (64.0.3282.167), latest Firefox (58.0.2).
- By SeanBailey Date 2018-03-01 12:35
Thanks, more info is always nice :grin:

There are a few too many mirrors in smoke filled halls around here, but we may have identified the root of the timeouts
(the query probably returned faster for me since you had recently run it and it was likely pulling some info from a cache).
Anyway, I can confirm the issue is not with you - and with luck will be a non-issue soon(ish).

Sean
- By amsayer Date 2018-03-01 12:45
Sounds good, thanks! This order will be it from me for the moment, but it's possible I will pull another large order in a few months. If I have similar issues again I'll update you, but if not then consider no news is good news. :)

Andy
Up Topic Products and Algorithms / Satellite Data Access / L1/L2 Browser error for large searches

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill