Not logged inOcean Color Forum

The forum is locked.

The Ocean Color Forum has transitioned over to the Earthdata Forum ( The information existing below will be retained for historical reference. Please sign into the Earthdata Forum for active user support.

Up Topic SeaDAS / SeaDAS - General Questions / Cannot Reproject L1 Browse files using gpt
- By alakes Date 2017-03-08 11:55
I was trying to batch process MODISA files from L1 to L3. When I tried to reproject or Mosaic the Local Area Coverage L1 browse files using gpt (Reproject & Mosaic operator) it is showing the following error.

  at gov.nasa.gsfc.seadas.dataio.SeadasFileReader.<init>(
  at gov.nasa.gsfc.seadas.dataio.BrowseProductReader.<init>(
  at gov.nasa.gsfc.seadas.dataio.SeadasProductReader.readProductNodesImpl(
  at org.esa.beam.framework.dataio.AbstractProductReader.readProductNodes(
  at org.esa.beam.gpf.operators.standard.ReadOp.initialize(
  at org.esa.beam.framework.gpf.internal.OperatorContext.initializeOperator(
  at org.esa.beam.framework.gpf.internal.OperatorContext.getTargetProduct(
  at org.esa.beam.framework.gpf.Operator.getTargetProduct(
  at org.esa.beam.framework.gpf.graph.NodeContext.initTargetProduct(
  at org.esa.beam.framework.gpf.graph.GraphContext.initNodeContext(
  at org.esa.beam.framework.gpf.graph.GraphContext.initNodeContext(
  at org.esa.beam.framework.gpf.graph.GraphContext.initNodeContext(
  at org.esa.beam.framework.gpf.graph.GraphContext.initOutput(
  at org.esa.beam.framework.gpf.graph.GraphContext.<init>(
  at org.esa.beam.framework.gpf.graph.GraphContext.<init>(
  at org.esa.beam.framework.gpf.graph.GraphProcessor.executeGraph(
  at org.esa.beam.framework.gpf.main.DefaultCommandLineContext.executeGraph(
  at org.esa.beam.framework.gpf.main.CommandLineTool.executeGraph(
  at org.esa.beam.framework.gpf.main.CommandLineTool.runGraph(
  at org.esa.beam.framework.gpf.main.CommandLineTool.runGraphOrOperator(
  at org.esa.beam.framework.gpf.main.GPT.main(
  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
  at sun.reflect.NativeMethodAccessorImpl.invoke(
  at sun.reflect.DelegatingMethodAccessorImpl.invoke(
  at java.lang.reflect.Method.invoke(
  at com.bc.ceres.launcher.Launcher.launch(
  at com.bc.ceres.launcher.Launcher.main(

Error: java.lang.NullPointerException

But the brs file is opening in SeaDAS7.4 GUI and there I was able to reproject or mosaic these files.

Brs file is generated using the following command:
$SeaDASPath/run/bin/linux_64/l1brsgen ifile=$L1BFile ofile=$BrsFile geofile=$GEOFile atmocor=1 oformat=hdf4 oformat_depth=24bit subsamp=1 sline=1 \
eline=-999 spixl=1 epixl=-999 >$LogFile3

Gpt Command used for reprojection: -e Reproject.xml -Ssource=$infile -PopReprojectFN=$ReprojOP

used xml file:(Reproject.xml)
graph id="Reproject">
  <node id="Reprojection">
        SPHEROID["WGS84", 6378137.0, 298.257223563]],
      PRIMEM["Greenwich", 0.0],
      UNIT["degree", 0.017453292519943295],
      AXIS["Geodetic longitude", EAST],
      AXIS["Geodetic latitude", NORTH]]</crs>
  <node id="writeNode">

These commands and graph files were working fine before installing SeaDAS 7.4 but Now SeaDAS GUI can do the job but GPT can't.

** Tried with increasing gpt memory, seadas memory upto 16 Gb.

Is it a problem of l1brsgen or GPT ?

Any suggestion is welcome.
- By aynur Date 2017-03-08 19:29
Thank you for reporting this problem. We have identified a bug that affected gpt operators and have fixed it. Please update the "NASA OBPG Ocean Color Product Reader" module of SeaDAS 7.4.

From SeaDAS application window, go to "Tools" -> "Module Manager ..." -> and click on the "Module Updates" tab. It should display the new module. Select the new module and ensure it is updated.

- By alakes Date 2017-03-14 14:11
Thanks for the help..

- By oo_processing Date 2017-05-30 14:06 Edited 2017-05-30 14:10
I have been trying to resolve this issue as well. When I follow the directions and click on the update module tab, it ends up freezing.
The JRE is defined in the seadas script as follows:
See image attached.
- By gnwiii Date 2017-05-30 15:00
For me, Module Manager takes a very long time to scan.  The progress bar often stalls, but usually starts to move again.  If it realy fails, you should get an error popup.

Since you know you want the seadas-reader-1.7.2 module, it is faster to update manually.  Some hints are given Module Manager Help.  This points you to preferences to get the Module Repository.  The "Note" at the bottom tells you how to install and remove modules manually.
- By oo_processing Date 2017-05-30 16:59
Disregard the previous post. It appears that if you leave it long enough, it actually does finish scanning.
- By oo_processing Date 2017-05-30 17:07
Thanks, the manual d/l and install was perfect!
Up Topic SeaDAS / SeaDAS - General Questions / Cannot Reproject L1 Browse files using gpt

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill