Not logged inOcean Color Forum

The forum is locked.

The Ocean Color Forum has transitioned to the Earthdata Forum (https://forum.earthdata.nasa.gov/)

Up Forum
Search
Topic Building on Ubuntu 18.04 By jasonlefler Date 2018-06-22 15:58
Just for some extra closure, this problem is caused by inconsistent default shells between OSes.  Of the /bin/sh links/binaries, these are the most common (as far as I can tell):

- symlink to bash shell
- symlink to bash shell in compatibility (POSIX?) mode
- dash shell binary
- there's a few others like ash, etc, that I've never personally seen in the wild but I know they're out there

Officially, using == is invalid, but Bash will (sometimes, usually, always?) allow it.  Dash won't (usually or ever?), which Ubuntu uses in 18.04.  There's a movement for OSes to switch away from Bash for their default /bin/sh to speed up boot times, etc.  I'm guessing that's why the invalid syntax went unnoticed for so long; OSX, which most of those blocks are for, probably set /bin/sh to Bash.
Topic Building on Ubuntu 18.04 By jasonlefler Date 2018-06-21 13:43
That would do it.  Shell scripts use a single equals sign for string matching.  I know there's a couple more of those floating around, we'll see if we can patch them up.
Topic Building on Ubuntu 18.04 By jasonlefler Date 2018-06-20 23:25
A bit of some good news/bad news here.  Good news, OCSSW builds just fine on 18.04, with a single minor patch.  Bad news, I couldn't reproduce any of the problems shown, except the xdr package problem.  (Sidebar: the code in xdr that the compiler complains about worries me, as well; it does look like they're missing some brackets and I can't say with confidence if it's a typo or a style choice.)  Setting the CFLAGS variable at the top of opt/src/BuildIt.env to "-Wno-misleading-indentation" got xdr through compilation and everything else went smoothly.  My install is a fresh install of 18.04 from the Live CD, x64, using the Minimal Install option when it came up and only the following packages installed via apt:

csh tcsh unzip git cmake bison flex zlib1g zlib1g-dev libx11-dev subversion gfortran gcc g++

(gfortran, gcc, and g++ are all version 7.3.0.)

Where did you download the opt/ src tree from?  What version does sdptk say it is?  I guess I'd try commenting out the unzip (tar) command in sdptk/BuildIt, manually unzipping it, and modifying the last handful of lines in TOOLKIT/bin/INSTALL with a metric ton of debug commands, such as `env`, `echo $script_dir`, `ls $script_dir` and `ls $LIB3_DIR/src/sdptk/TOOLKIT/bin`.  (I'm only assuming that INSTALL script is the right one.)
Topic My subscriptions are empty By jasonlefler Date 2017-07-28 13:47
First of all, thank you for the clear and detailed steps to reproduce the error; that was invaluable.  The problems you were seeing should be resolved.  Some time ago, we combined the extracted and non-extracted data sections into one and it seems a variable somewhere or other wasn't changed along with the rest of it.  If you run into any other problems, please don't hesitate to shout.  And thank you for your patience, it took longer than expected to track this issue down.

Jason
Topic automating data from AERONET-OC station By jasonlefler Date 2017-03-27 10:37
<Previous post deleted.>

That question is better addressed to AERONET themselves.  If they don't intend for data to be downloaded via command line, doing so may be violating a user agreement or terms and conditions.  That being said, using wget or curl to emulate what a browser does is a common starting point for automating sites without proper APIs, such as SeaBASS.  While we don't mind scripts being used to download data, simultaneous requests and many, many requests with no delay in-between is often seen as abusive and may get an IP address temporarily banned.  AERONET's stance on how to appropriately use command line tools, if they're allowed at all, is up to them.

Jason
Topic L1 Browser order request fails By jasonlefler Date 2017-03-16 10:54
Sorry about that, looks like I overwrote a file I shouldn't have.  It should be all fixed now, give it a shot.
Topic No data access - just me? By jasonlefler Date 2017-01-11 11:40
The whole site seemed to have had a hiccup, but it should be working now.
Topic in situ measurements (Rrs) By jasonlefler Date 2016-10-12 02:28
Landsat 8 has a very narrow swath width; ~115 miles vs. ~1500 miles for Aqua-MODIS.  It'll be difficult to get many coincident points at all, let alone ones that fit our quality criteria.  You could try cranking down the settings on our validation search.

That having been said, AERONET is another data source with reasonable coverage.

Jason
Topic MERIS FRS access By jasonlefler Date 2016-04-21 15:44
Alrighty, that one is a slightly separate issue.  For URS, a user must pre-authorize an app/website before they can access it via command line (there may be some CLI jiggery-pokery you could do, but you're not supposed to, with plenty of air quotes).  For MERIS, you not only have to pre-authorize the application, you also have to fill out a form before you can download data.  To do both of these things, first use a browser to download a data file.  Once you get through that, that cURL command should work just fine for any other file.
Topic MERIS FRS access By jasonlefler Date 2016-04-19 16:57
Wget does seem to be having trouble logging in.  For me, it's retrieving the login page instead of the data file.  cURL seems to work just fine.  The Data access FAQ on bulk downloads has a bit of information, as does Earthdata's page on cURL and Wget.  Wget had worked before, so I'd probably just switch to cURL since we can't really track down the problem.  In short:

touch ~/.urs_cookies;
for file in $(cat path/to/filelist);
do
  curl -u username:password -b ~/.urs_cookies -c ~/.urs_cookies -L -n -O $file;
done;


I'd recommend setting up a ~/.netrc file (described in both of the above links) and omitting the -u username:password bit.
When generating the CSV file for the data, it will also include any associated Rrs data.  Just hit the Generate Data File button above the search results while POC is selected, give it time to finish, and hit Download Data File.  It's not actually a CSV but a SeaBASS format with some extra information on the search that generated it.  A few seconds in any old text editor or spreadsheet application and you can convert it to one for easy data parsing.
It is not possible to tell which processing version it's using, nor which was used when loading old permalinks.  We are working on re-coupling SeaBASS's version names with the official version naming but it's still a long way off -- too much of our internal code is looking for "operational."  I'm not even sure which processing versions SeaBASS considers operational, I'll ask my colleague.
Topic HICO data access / EOSDIS issue By jason Date 2015-03-23 20:46
Sorry about that, we've been having some certificate problems with ECHO's servers and it looks like our fix never found its way to our data servers.  You should be all set, but, due to how our server caches things, you might have to retry a couple times (only failed once for me before it worked, but YMMV).
Topic SeaBASS satellite-insitu matchup generation By jason Date 2014-07-21 18:38
The matchup system will directly compare wavelengths that are close.  In general, it allows for about plus or minus 5nm.  For example, anything between 486nm and 492nm, inclusive, will match 486nm for VIIRS, 488nm for Aqua/Terra, and 490nm for SeaWiFs/OCTS/MERIS.  The value will be used as-is and not interpolated.

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill